ICE>LINK software, Dension config files, iPod in your car, update ice>LINK

Following on from previous posts, you can now download all versions of Dension’s firmware here, including versions 2.03, 2.04, 2.05, 2.06, 2.07 and 2.10. Included in the zip file are the config files for all of the head units that Dension supported, both OEM and aftermarket. Additionally there are the update instructions and the start update.mp3 file.

Click here to download them all – it is a 4.1MB download…

Edited – Feb 18th 06, Check out the page for Dension files – all versions in the updates library are now listed individually, along with the config files and a .pdf about how to run the updates. Hopefully this will help folk get to the exact update they want more swiftly.

41 thoughts on “ICE>LINK software, Dension config files, iPod in your car, update ice>LINK

  • 17 March, 2006 at 4:47 pm
    Permalink

    OK – so you’ve got the dension installed and you have downloaded the firmware files and the correct config file for your car… you’ve loaded these on to the iPod (in the usual way you add files to your iPod) and you have set the ‘setup’ file to play, then plugged the iPod in to the dension cradle.

    Once that has completed you *should* be able to use the CD changer button on the HU to select the iPod. Have you done these things, or are you still to get the config and firmware files loaded on?

  • 10 July, 2005 at 3:58 am
    Permalink

    Hi there, thanks for your great links to the ICE>LINK software, I just purchased one for my Panasonic head unit but have yet to install it. How do you use the config and clear unit files in your download? I couldn’t find instructions for those. Thanks again!

  • 1 January, 1970 at 10:14 pm
    Permalink

    thankyouthankyouthankyouthank thankyouthankyouthankyouthankyouthankyouthankyou!

    Firmware 2.07 makes everything works on my car! Yeah! Why Dension do not offer those for download is beyond me…

  • 24 January, 2006 at 4:18 pm
    Permalink

    Got an Ice link plus and just installed v 2.07 its now made the very small, high resolution info on my video ipod now big at crapply low block res!! I hope the v2.10 that you have on your site will make things a little better – on the whole its a great product with quite a lot of lag between the song changing and display on the screen….and now Id3 tag displayed on my sony head unit despite having CDtext….hopefully dension will get round to sorting this…?

  • 16 January, 2006 at 8:56 am
    Permalink

    You spam my blog with this again YOUR REPORTED YOU PIECE OF CRAP!

    123 Online Cash

    [snip] and much much more nonsense besides this from 69.46.24.56

  • 17 January, 2006 at 9:48 pm
    Permalink

    Sadly, I think you have got the wrong end of the stick – I am not in the business of passing on spam. It appears to me that my blog or email has been used by a spam bot when posting this on your site.

    I’d apologise if I thought I was in the wrong, but clearly you haven’t got a clue about how these things work or how to recognise a responsible blogger. Who exactly would you report me to? And for what?

    Time to do some growing up, I think.

  • 17 November, 2005 at 3:42 am
    Permalink

    I am confused as to how you get it to update. I tried to follow up the update instructions from Dension manual ie. invoking update via their update menu. Nothing happens.
    Are you suggesting that by starting to play Start_Update.pm3 and placing iPod in the Dension craddle you will actually complete the update? Can you be more specific on the actual steps which need to be done? It will be greatly appreciated.

  • 27 November, 2005 at 6:51 pm
    Permalink

    That’s exactly it – you play the track in the iPod and place it into the cradle. This updates the firmware on the Dension device. Personally, I used to place the iPod in the cradle first and then play the track, but either way should work. It isn’t anything harder than this, honest!

  • 29 November, 2005 at 4:39 pm
    Permalink

    Great site. These firmware updates, are they for ICE>LINK PLUS, or just ICE>LINK (if there is, indeed, a difference) and do you know what added benefits the different versions deliver? Thanks.

  • 3 September, 2005 at 12:43 pm
    Permalink

    The config and clear files are just MP3 files which you play through your iPod… one will clear the Dension unit of any other configurations whilst the other will load the info about which head unit the Dension is attached to.

    Just start the appropriate one playing and then put the iPod into the unit and it will do it’s thing 🙂

  • 30 November, 2005 at 5:41 pm
    Permalink

    Have just installed an ice-link plus in my C class mercedes and the sound is great. However I cant access the setup menu’s properly due to teh limited number of head unit buttons on my car stereo (Audio 10). If anyone has any suggestions I would be greatful.

  • 2 December, 2005 at 8:20 pm
    Permalink

    Sorry to hear this! What buttons do you have, and what set up items can you get to? If you can post some images of the head unit, or links to those images, it will help…

    Have you asked at the hackmycar forums?

    http://www.hackmycar.com/forum/index.php

    I have to say that since the last post there was two weeks ago I wouldn’t have thought there is a good deal going on.

    Finally, have you tried to contact Dension directly? Some folk do have problems getting in touch with Dension, but others seem to get good support.

    http://www.dension.com

  • 2 December, 2005 at 8:24 pm
    Permalink

    Not at all sure, I’m afraid. If it’s of any use, I have an Ice>Link, I believe – but I stopped using it last May when I got my Alpine HU with the KCA420i adapter. I can’t tell you how much better this combination is, but that doesn’t really help you folk still working with the Dension kit… sorry!

  • 19 February, 2006 at 10:52 pm
    Permalink

    How did you get on with it?
    How did you get on with it?

    I never installed anything later than 2.05, and found this to be OK for what I needed. I kept the iPod interface as well, rather then the Dension one which I found rather less than good.

    Any feedback about these firmware files will be useful…

  • 14 March, 2006 at 6:01 pm
    Permalink

    I just have a problem because ones I select the cd the only thing I hear is a warning sound and it doesn’t chage to the cd player. Could you then be a little bit more specific about what to do? Thanks

  • 7 March, 2006 at 4:22 pm
    Permalink

    NO RADIO CONTROL – LOCKED OUT OF DENSION UI AND IPOD UI

    I installed IceLink Plus in my 2002 TL and cannot access the menus in the dension UI. I have forced the update to firmware version 2.15, and made sure that my iPod has the newest firmware (I have a 30 gig with dock), and still no access. I can play music before I put the iPod in the cradle and it plays and charges fine. If I just put the iPod in the Dension cradle, then it goes to the playlist menu, and I cannot choose anything with the radio buttons or my iPod buttons. I have the OEM radio that I know a bunch of people have hooked up to.

    Any suggestions on this problem?!?!

  • 7 March, 2006 at 9:38 pm
    Permalink

    Hi – thanks for the comment, and sorry to hear that you are having trouble.

    A couple of thoughts – have you loaded the correct config file for the radio – some folk try to use the radio manufacturer config file and not the car manufacturer even though they ahve got a factory fitted HU. If you have got an Audi, for example, you should use the Audi config files regardless of the fact that the radio is a blaupunkt. However, if you are using an aftermarket HU then use the relevant radio config files.

    Secondly, if you can, try removing the configuration from the Dension – the instructions were on the dension site, but it basically consists of loading a blank config file. This will return the dension back to the state it was in when it left the factory… you can then try to re-install the correct config files for the car you have got.

    Finally, head over to the two forums listed in the panel on the left of the page (hack my car and iPod my car) to see if anyone there can help you further.

  • 27 July, 2007 at 1:57 pm
    Permalink

    It appears from a couple of remarks above that the firmware update option in the IceLink menu is not necessary to get the thing to update using a firmware update playlist.

    If it’s the case that the only thing required is to play the setup playlist, then should I be hearing the beeps as it plays the files?

    Daniele

  • 27 July, 2007 at 8:30 pm
    Permalink

    You shouldn’t hear anything as the update proceeds… at least, I certainly never have. That said, I stopped using the Dension product about two years ago and keep this thread and the config files for all those folk still looking for the earlier versions. Dension themselves are not updating the ICE>Link firmware anymore, afaik, with a message on their website stating that they consider the last version to be suitable for all devices. Hmmm.

  • 27 August, 2007 at 8:03 pm
    Permalink

    Where can I find the update version 2.07

  • 27 August, 2007 at 9:14 pm
    Permalink

    Hi Damon – have a look in the page called ‘Dension Files’ (Link Here), there is a click through to the v 2.07 files there. Alternatively, the download from this page (see the link in the text at the post at the top of the page) will have *all* of the files for each of the versions I have got.

  • 29 December, 2007 at 2:29 am
    Permalink

    Hi,

    I keep having problems that I can not see Icelink menu while connecting to my BMW Business CD (E46, 2003). Tried update, re-configure several times, but still can not see the menu.

    While playing music from iPod, I can hear music from HU but can only control iPOD directly on it not via HU or driving wheel.

    Any suggestion or solution?

  • 25 January, 2008 at 12:48 pm
    Permalink

    Hi,

    I have a very similar problem as Kev. Using Icelink plus V2.03 with CD43 HU in 1997 BMW 325tds. I can play, FF and RW via HU but cannot access Icelink menu via HU by pressing CD6. Tried to update and re configure but it wont update or accept new fimware. Very frustrating.
    Help appreciated.

    Gart.

  • 14 June, 2008 at 6:29 pm
    Permalink

    I have tried the down loads but my Ipod comes back with visit Dension web site for download/ well finally downloaded but still say’s to visit dension, the version was 22.11 is now C10. I have also disconnected the unit for 30 minutes, still no luck. I have a mazda rx-8.

  • 21 June, 2008 at 2:58 pm
    Permalink

    Hi!
    I have just downloaded the firmware update v2.18 as I am connecting my iPhone to my ice>Link Plus v2 (Audi). I start the Start_Update song and connect but after 3 or 4 seconds the first track in my library plays. Dension’s instructions implied the process would take about 5 minutes. Any clues?

  • 22 June, 2008 at 1:10 am
    Permalink

    I am not sure whether the iPhone will work as expected with the Dension ICE>Link… I can’t see why it won’t but you can never be sure. Have you contacted Dension to see if the iPhone is supported? Have you tried other firmwares? What config file are you using?

  • 7 July, 2008 at 8:18 am
    Permalink

    Hi, I have a 2006 A8 with MMI High. I have been trying to fit the Dension 500.
    I have wired it up and hooked up all the Optic fibre links, but the unit does not appear to switch on. The whole Audi MMI system will not turn on past the opening screen. The LED on the AUX unit does not light up (is it supposed to?) the system is in the same state as when the optic links are simply disconnected. It all works fine when the Dension is removed from the loop again.
    The only thing I have not done is press the reset button on the Dension; would this have any effect? Please can you give any suggestions? I was very excited about fitting this piece of kit, but now I am thinking I made an expensive mistake!! Best regards, Andrew.

  • 10 July, 2008 at 7:58 am
    Permalink

    my iphone worked great with my dension icelink.

    then i sold my ipod…

    shortly after, the dension went into the head unit mode, which doesn’t allow the iphone to control the dension, only the head unit can control the icelink, and via the iphone i don’t get the dension menu…

    does anyone know how to put the dension into the ipod/iphone mode that let’s the ipod/iphone change music instead of head unit only???

    or do i have to borrow an ipod in order to get to the menu again???

    i hope dension updates the icelink ASAP in order to fully support the iphone…!!!

  • 10 July, 2008 at 7:59 am
    Permalink

    i’m using the icelink with my new beetle OEM radio setup, works flawless except the menu snafu…

  • 5 August, 2008 at 8:25 pm
    Permalink

    Hi there guys.
    i have a bmw business head unit..ive followed instructions carefully and managed to update firmware onto the ipod and played the update playlist on it,but pressing number 6 does nothing.and therefore i cant access playlists apart from the first 5 also no titles come up..any ideas..

  • 13 October, 2008 at 9:13 pm
    Permalink

    Hi,
    A note for BMW users: I downloaded v2.15 from tomtek.de and then read the history_21x file. It states that from 2.1x versions a seperate BMW version would be released. Perhaps this explains why BMWs don’t work with the standard files?
    Hope this helps?
    Mark

  • 27 October, 2008 at 11:01 pm
    Permalink

    ive got a problem with my ice link plus & iphone , this is very weird and is really bugging me. it was working fine i could control music from the actual iphone when in the dock. but not for some od reason everytime i put it in the cradle it says accessory connected and i can only control it using the head unit controls…… i cant get to any of the dension menu either

  • 28 October, 2008 at 9:21 am
    Permalink

    RK – I’ve not used an iPhone with the Dension, but maybe someone else here has. What version of the firmware are you running? You also mention a ‘dock’ and a ‘cradle’… could you clarify what you mean? Do you have a wire that connects to the iPhone dock connector (bottom of iPhone) or do you have a cradle which the iPhone sits in… or do you have both?

    If one works but the other doesn’t, are you sure the other is connecting correctly? Have you got fluff inside the iPhone dock connector?

    What head unit is this attached to?

  • 1 November, 2008 at 9:33 pm
    Permalink

    Hi All,
    Here’s some feedback from my recent experience. It is a golf Mk 5, with an 80GB ipod clasic (with latest software) and an ebay purchased ice link plus.

    My problem was I could not access the Dension UI menu system. I could play music and advance/retard tracks, but that was it.

    I tried several versions of firmware and none would upgrade. They would get 5-10 ‘tracks’ through and crash out back to the first alphabetic song on the ipod.

    I contacted Dension support via their website and they were responsive and helpful, however, they didn’t solve it.

    They did point out there are two versions of the ice link plus and you need to use the right software version. You can tell easily when the DENSION UI starts when you dock your ipod – the top right window in mine read version 4-4.15, so I needed v4.xx firmware. Otherwise it is v2.xx firmware. It is also on the sticker on the DENSION unit if you want to disassemble your car again.

    Eventually I removed everything from the ipod and reinstalled just the upgrade firmware and HEY PRESTO it worked!

    I had resisted this as I thought it might be onerous in itunes but it was easy. With your ipod connected to your PC and itunes running, in the sync part tick ‘manually manage music and videos’ and take it from there, it is quite simple. when finished you untick this and itunes then resyncs your library.

    Hope this helps!

    Mark

  • 18 December, 2008 at 5:28 am
    Permalink

    I use the icelink plus with a Sony HU and an iPhone. This week the Denison decided it wanted control and I got the iPod accessory message. Tried updating firmware via iPhone by playing the correct song but like others I had no luck. The easiest solution was to plug in a regular iPod and switch back to ipodUI mode. Everything fine until it does this again. Would be nice if there were an iphone app to handle upgrades. On a side not I bought a $40 adapter for the dock connector the reroutes the power pins so I can charge while plugged in. If anyone finds a solution please let me know via Twitter. Twitter.com/chrisohare

  • 18 December, 2008 at 9:00 am
    Permalink

    Thanks for the input Chris.

    I have now changed my car and instead of the Alpine HU I am back to the Audi supplied systems. However these days you can ask for an iPod connector pre-fitted into the glove box. Surprise, surprise, it is the Dension system again… so I am back to where I was four years ago!

    It does work with the iPhone even though it complains about it not being compatible. It works well with the iPod touch, too… better than I expected. It took a while for it to simply work with an older 3G ipod and the original iPod Nano from about three years ago… but it did kick in to gear eventually. I didn’t need to run any updates at all. The system does power all of the iPods I’ve tried it with – which is pretty much everything since 3G ones that hav a dock connector. And it leaves the control on the iPod but gives me a basic control via the head unit.

    So I’m a little baffled as to why yours doesn’t charge… and why it switched to the different control system.

  • 11 February, 2009 at 5:43 am
    Permalink

    I have Ice Link PLUS with MFD2. Was 4.15 Sw version, now have 4,16. Few problem on that. has been frozen, now just see only one playlist (in Ipod is 5) even when I’m go to 2,3,4 CD this still playing me this same song. ignition OFF, back on after few hours , still nothing. make me confuse. Im gonna make something with frimware today, or use this cleaf file (aftermarket) if not help, f**** sale this and buy Phatnoise,

  • 12 February, 2009 at 12:35 am
    Permalink

    I totally understand your frustrations, Martin – I too bought one of the early Dension devices, loved it and hated it all at once. I still have it, but replaced my head unit with an Alpine system that has a direct iPod connection. It was fantastic by comparison, giving me total control over the iPod, showing track titles in the display and everything you would expect. However, I bought a new car, and am back to a factory fitted iPod interface… which happens to be another Dension ICE>Link… d’oh! I have got two of them now.

    The latest one works reasonably well, so I am not going to update firmware or anything. I have at least one iPod hat it works with, and whilst I don’t get track names appearing (I can’t believe that still isn’t sorted) I do at least get control of the iPod through the head unit.

    Eventually I will get fed up with some aspect of it and search for an alternative. The trouble is, there are precious few choices available that can fit to the factory head unit. I then have to decide if it is worth while dismantling it all and starting again, and compromising on something else that currently works well.

    Never easy, eh?

  • 12 February, 2009 at 2:44 pm
    Permalink

    Unfortunatelly I have navigation In dasch, so the new one with touch screen etc , cost me about 1000GBP, so In not really able to do this. Few years ago had some genuine VW ipod interface. Was very good, only one problem with playlist. When ignition was of and back on playlist 5 was on the number 1, so Im newer knew where is my favorite songs. We will se how long I will keep this Dension.

  • 28 February, 2009 at 5:35 pm
    Permalink

    Hi, I have icelink plus and bmw e46 bussines tape. I can not see song text in my radio (i can read RDS and radio station names) I tried to make it active from disc 6 menu but when it says select disc3 i select but nothing happens.So i decided to update firmware but first of all i don’t know which version will i choose? v2 or v4 also i dont know my version too. i installed vers v2b for bmw and copied all the files(about 600) i ve followed the instructions i went to my car opened the radio,but didnt plugged to icelink, started playing start update.mp3 then plugged the ipod to icelink but update didnt started radio started to playing my songs also same thing happened in the showing headunit to icelink nothing happens and it starts to play songs. I dont know what to do please help me.

Leave a Reply

Your email address will not be published. Required fields are marked *

* Copy This Password *

* Type Or Paste Password Here *

five × two =